Jump to content
Sign in to follow this  
jcsnider

Intersect Beta 4.9.1 Released!

Recommended Posts

984549685492.png

Intersect Beta 4.9.1 Released!

July 4th/5th 2018

 

 

Bug Fixes/Problems Solved:

  • Bank errors when withdrawing items.
  • Tilesets multiplying within the editor
  • Combat crashing when no weapon slot is configured
  • Critical hit text fixed! (Delete your Server/Resources/Languages/* files for the updated one to generate)
  • Invalid textures and sounds being able to crash the client and editor
  • Negative hp/mp spell costs allowing health/mana to exceed maximum values
  • Erase tool placing tiles on click & drag in the editor
  • Time not displaying correctly in event dialogs when time is set to sync with the server
  • World screenshots crashing due to a memory leak
  • Various editor crashes when saving maps, loading maps, linking maps, etc
  • Crashes when trying to modify existing event commands
  • Unexpected delays/channeling warnings when trying to cast spells back to back that have 0 cast time.
  • More!!

 

Updates:

  • There is now an option to disable animation rotations in the animation editor!

 

08ca285f8e3b987fa2fd2bc2f2144808.png      85f11b929ce09c3a11bf6298cd6e915e.gif

 

4.9.1 Hotfixes!

  • Extremely low fps bug that has impacted some users since 4.2!
  • Server bug that was being overprotective and sometimes canceling players' attacks.

 

 

 

 

 

Up Next

We're wrapping up the major database changes in B5 finally.. so we'll implement the new features and get that out ASAP!

 

Download

If you're already using 4.3, 4.4, 4.5, 4.6, 4.7, 4.8, 4.8.1, or 4.9 just download 4.9.1 and overwrite your .pdbs and .exes and run the migration tool! :D

Download

 

As always please keep in touch with us and report all bugs that you find!

Share this post


Link to post
Share on other sites

Topic updated!  I just released 4.9.1!!!

 

4.9.1 has two hotfixes that has impacted a small percentage of our user base:

  • Extremely low fps bug on some machine that has impacted some users since 4.2!

  • A server bug that was being overprotective and sometimes canceling players' attacks.

I want to give a massive thanks to one of our newest members @LinkTaylord for allowing me to use his pc to debug. Even if you aren't experience these errors you might as well grab 4.9.1. I will go get back to work on B5.

 

jcico out  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×