Jump to content
  • 0
Sign in to follow this  
eins

Nuget cant restore Monogame packages

Question

Hi there,

 

just wanted to compile Intersect for the first time. I followed the instructions, but NuGet wont load the Monogame package for me.

7qZD3oT.png

 

When i go to manage NuGet packages for solution i seemingly only see older versions?

 

ECgyvkL.png

 

I tried setting Package source to "all" (which showed the newer Monogame versions in the drop down) and then the "restore" in the box on top, but that didnt seem to work as well.

 

 

Edit:

Further investigation shows the file it tries to download is

http://teamcity.monogame.net/guestAuth/app/nuget/feed/_Root/default/download/MonoGame_DevelopWin/96508:id/MonoGame.Framework/DesktopGL/Release/MonoGame.Framework.DesktopGL.3.8.0.1217-develop.nupkg

which has probably somehow gone missing?

There is also nothing here http://teamcity.monogame.net/viewLog.html?buildId=96508&buildTypeId=MonoGame_DevelopWin&tab=artifacts

while the newer version shows the files http://teamcity.monogame.net/viewLog.html?buildId=97601&buildTypeId=MonoGame_DevelopWin&tab=artifacts

 

I tried removing the packet from the solution and instead added the 3.8.0.1336-develop version, but it seems like the old version is still referenced somewhere?

J70Y6oa.png

 

 

Edit again:

I manually changed 1217 to 1336 in the Intersect.Client.csproj and at least now it compiles... but fails right after launching the client :(

Exception thrown: 'System.ObjectDisposedException' in mscorlib.dll

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I had some weird stuff going on with NuGet packages and github at the beginning and ended up having to restart my computer for it to work. Not sure if it has any association with this issue, but hey -shrug-

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Lathander said:

I had some weird stuff going on with NuGet packages and github at the beginning and ended up having to restart my computer for it to work. Not sure if it has any association with this issue, but hey -shrug-

 

Thanks, i tried that, but it didn't help.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, jcsnider said:

Got a solution in the pipeline:

https://github.com/AscensionGameDev/Intersect-Engine/pull/193

 

Looks like MG prunes their dev builds so we uploaded a copy of the missing version to our own Nuget. Not the best solution but only temporary until 3.8.X is deemed stable.

 

How can i get this solution ? Still had a trouble when i try to generate solution :/

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...