Jump to content
  • 0
Estrary

Change the IP??

Question

I installed intersect and went to launch the server and it couldn't connect to the local IP. I figured that I could change the IP somewhere to either Hamachi or something like that. Obviously I tried the fixes when it told me it couldn't connect. I turned my firewall off, and nothing. I attempted to reinstall it thinking I messed something up. That didn't work. Antivirus program wasn't blocking it at all, and I know I have permission to use ports considering i've done it a quadrillion times. Nothing has changed with my router or anything to make it so it would just up and quit allowing me access with it as well. I also was using Intersect like a week ago or so.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1

Open your client folder and go to /resources then open the config.xml (i use notepad++ but any text editor will do)

 

<?xml version="1.0" encoding="utf-16"?>
<!--Config.xml generated automatically by Intersect Game Engine.-->
<Config>
  <Language>English</Language>
  <Host>127.0.0.1</Host>
  <Port>5400</Port>
  <RenderCache>true</RenderCache>
  <MenuBgm />
  <MenuBG>background.png</MenuBG>
  <Logo>logo.png</Logo>
  <IntroBg />
  <Font>arial</Font>
</Config>

Edit the   <Host>127.0.0.1</Host> to the servers IP.

 

Since you seem familure with other settings such as ports and your firewall ill skip that.

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, defaultx said:

Open your client folder and go to /resources then open the config.xml (i use notepad++ but any text editor will do)

 


<?xml version="1.0" encoding="utf-16"?>
<!--Config.xml generated automatically by Intersect Game Engine.-->
<Config>
  <Language>English</Language>
  <Host>127.0.0.1</Host>
  <Port>5400</Port>
  <RenderCache>true</RenderCache>
  <MenuBgm />
  <MenuBG>background.png</MenuBG>
  <Logo>logo.png</Logo>
  <IntroBg />
  <Font>arial</Font>
</Config>

Edit the   <Host>127.0.0.1</Host> to the servers IP.

 

Since you seem familure with other settings such as ports and your firewall ill skip that.

Well whenever I changed the host it's still trying to run off of the my local IP and when I load up the server after i've changed it to the Hamachi IP the server will still be running off my local IP.

I went through some of the other folders looking to see if maybe the Host was in another place, but I couldn't see anywhere else that would force it to run off my local IP even after I changed it.

Share this post


Link to post
Share on other sites
  • 0
On 9/12/2018 at 2:45 PM, Estrary said:

Well whenever I changed the host it's still trying to run off of the my local IP and when I load up the server after i've changed it to the Hamachi IP the server will still be running off my local IP.

I went through some of the other folders looking to see if maybe the Host was in another place, but I couldn't see anywhere else that would force it to run off my local IP even after I changed it.

<Host>127.0.0.1</Host>

change this to the IP you wish to use. For Example if 123.33.44.55 was my IP that I was using I'd do

<Host>123.33.44.55</Host>

Share this post


Link to post
Share on other sites
  • 0

The server “listens” on all available network adapters or ip addresses but the IP address that is shown in the console is the IP address that you browse the web with. As long as hamachi is running your clients can install hamachi, connect to your network, and use your hamachi ip to contact the server. 

 

You cannot change the ip the server recommends when the server boots. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×