Jump to content
  • 0

Doubt about "prerelease" branch build



Hello guys! Not so long ago I started working with the source of the intersect engine so I still have some doubts!


After forking the repository, I created a new branch from the master! I edited some codes according to my need, i gave build and everything worked 100%!

I tried using the "prerelease" branch to test some updates I saw in the patch note, but I didn't understand why I couldn't edit the assembly and basic information! Could someone explain this to me? 


Thank u!


EDIT: It seems when I build or rebuild develop or prerelease branch, doesn't appears nothing in debug folder!


Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 1

Start with Beta 7.1 the binaries are just put in the default directories, for example "Intersect.Client/bin/Debug/net462/" or "Intersect.Server/bin/Debug/net462/". All of the "build/<configuration>/<project>/" folders are dead starting with 7.1.

Assets are now no longer in "build/<configuration>/<project>/resources/" they are in "assets/development/client/resources/" for the client and editor or "assets/development/server/resources" for the server.

Using non-default output directories like we were using in 7.0 and before was causing issues with the change in project type (if you look at the .csproj files of 7.0 there's a million things and it's a gigantic mess, in 7.1 the csproj files are almost empty -- that was the project type change).

The new assets setup (since "assets/development/" is ignored by git) works really well and this is what my workspace looks like where I have both the Intersect-Assets and Intersect-Engine repos pulled, and I have a symlink on the resources directory so I can live-test the Intersect-Assets repo and update them as my client changes them.

Link to comment
Share on other sites

  • Create New...