Jump to content
  • 0
stormAD

How to play with friends?

Question

Good morning, good afternoon or good evening. I searched the forum, but I did not find anything clear about making the game work on another computer, in my case I want my friend to join the game with me to test and develop together. When the server starts it starts with port 5400 and on the client in the configs the ip "localhost" and when I change the "localhost" for an IP the server starts, but always goes offline. When I unzipped the files, I started the server, then the client, I created the account all the way up, then I accessed the client configuration and edited the ip with the notepad I wanted some help with that ...

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
1 hour ago, stormAD said:

Good morning, good afternoon or good evening. I searched the forum, but I did not find anything clear about making the game work on another computer, in my case I want my friend to join the game with me to test and develop together. When the server starts it starts with port 5400 and on the client in the configs the ip "localhost" and when I change the "localhost" for an IP the server starts, but always goes offline. When I unzipped the files, I started the server, then the client, I created the account all the way up, then I accessed the client configuration and edited the ip with the notepad I wanted some help with that ...

 

Hi, you need to open the port, go to the server, open the settings -server.json for friends there - enter your ip, then open the port that is listed there, your friends can connect, provided that you have a server and a port for this connection on your PC

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, stormAD said:

Good morning, good afternoon or good evening. I searched the forum, but I did not find anything clear about making the game work on another computer, in my case I want my friend to join the game with me to test and develop together. When the server starts it starts with port 5400 and on the client in the configs the ip "localhost" and when I change the "localhost" for an IP the server starts, but always goes offline. When I unzipped the files, I started the server, then the client, I created the account all the way up, then I accessed the client configuration and edited the ip with the notepad I wanted some help with that ...

client and editor -> resourses -> config.json - your ip - save
{
  "Host": "localhost",                   input your ip adress
  "Port": 5400,
  "RenderCache": true,
  "Font": "arial",
  "ChatLines": 100,
  "MenuMusic": "It_Devours.ogg",
  "MenuBackground": "background.png",
  "IntroImages": [
    "logo.png"
  ]

server -> resourses -> config.json - playerdatabase gamedatabase - input ip save
 "PlayerDatabase": {
    "Type": "sqlite",
    "Server": "localhost",                               input your ip adress
    "Port": 3306,
    "Database": "",
    "Username": "",
    "Password": ""
  },
  "GameDatabase": {  
    "Type": "sqlite", 
    "Server": "localhost",                input your ip adress                         
    "Port": 3306,
    "Database": "",
    "Username": "",
    "Password": ""
  }
}

Share this post


Link to post
Share on other sites
  • 0

Hello ! 
Can you explain us more details about your current setup ? 
What do you use : Personnal Computer ? VPS ? Dedicate Server ?
If in the case you use your own Personnal Computer you have some tools and step to do.
I have wanted to make a tutorial for making it working ^^ ! 

So here the step : 
First you need to setting up your Windows FireWall
Set in UDP the port "5400" by default or other number if you have change this number. You need to do it 2 times, Interne connection and Extern connection.

When this is done, you need to check your rooter/modem.
Does your modem allow the UDP port '5400' too ? 
For my case it's automaticly add with the first startup of the Intersect Server.exe ( when it's needed to start it in admin ).
If it's not added, you need to do it manually, it's not very complicated.

Good all the majors step are done. We can allow external connection to read us ip+port ( Only this one ).

You need now to get a DNS refresher or an other LAN software.
More effective in this case it's : No-Ip
or you can select : LoginMeInHamachi

For both using you need to creat an account on one of them device of your choice

When your No-Ip account is done download the DNS refresher Client ( DUC ) : Here
You need to make a custom DNS on this page : Here and press ' Create Hostname '
You need to put ONLY custom value on : Hostname text field & Domain like this : Exemple , and put ' Creat Hostname ".
Now you need to install the No-Ip Client ( DUC ) , log into it, you have to select your recent no-ip dns just created. and it's done !
You could use your External Public IP in clear, or the DNS 

You need edit the Client or Editor config.json for to be able to read the server on external computer.
1 Client or Editor for yourself who keep reading 127.0.0.1 ( I say you are on a Personnal Computer )
And need and other Client / Editor with modifier config.json who read the ' External IP or DNS "
The most effective it's reading by DNS cause the DUC make a refresh of your IP DNS every 5 minutes, so if you restart your modem you don't need to send again your External Ip it's done automaticly.

When your LoginMeInHamachi account is done you need to download the client : Here
Your friend need to do it too.
/ ! \ It's only a 14 days trials, but old version of this one was without this trials ( It's not a crack ! ^^ )
You need to creat a channel on this client
Your friends need to join it too.
Hamachi normaly return you a custom IPv4 IP, Copy it
And modify your Client or Editor config.json files with this IP.
You just need to make 1 copy of thoses folder, no need to make one for local and one for hamachi. It's work too :)

If you are on VPS / DEDICATED SERVER :
First you need to setting up your Windows FireWall
Set in UDP the port "5400" by default or other number if you have change this number. You need to do it 2 times, Interne connection and Extern connection.

Modify Client & Editor config.json files with your VPS / Dedicated server IP.
And it's done :) !

Happy if this helping

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, Jackson said:
 

Hi, you need to open the port, go to the server, open the settings -server.json for friends there - enter your ip, then open the port that is listed there, your friends can connect, provided that you have a server and a port for this connection on your PC

 

Clear my mind, I had forgotten to open the door, so really could not access, I will call my provider to release the door, I will test and soon I enter with feedback.

Share this post


Link to post
Share on other sites
  • 0

 

I do not know if I'm too dumb or some real problem that is stopping.

 

I'll give you my connection information: My Internet Provider provides through an optical fiber connection to a ONU in which the ip arrives to my router.

 

192.168.2.50 (according to them, this ip is open for port 5400)

 

Where is connected in the WAN port of my router TP-Link wr720N, which provides the following IP to my personal computer I want to use server.

 

192.168.0.100

 

 

I put the HOST name created in the NO-IP step in the client / resources / config the server started without any problem, recognized the UPnP in the router and informs that it is open to the public, but when I go to test the port, it says that it is not open

Share this post


Link to post
Share on other sites
  • 0
Just now, stormAD said:

 

I do not know if I'm too dumb or some real problem that is stopping.

 

I'll give you my connection information: My Internet Provider provides through an optical fiber connection to a ONU in which the ip arrives to my router.

 

192.168.2.50 (according to them, this ip is open for port 5400)

 

Where is connected in the WAN port of my router TP-Link wr720N, which provides the following IP to my personal computer I want to use server.

 

192.168.0.100

 

 

I put the HOST name created in the NO-IP step in the client / resources / config the server started without any problem, recognized the UPnP in the router and informs that it is open to the public, but when I go to test the port, it says that it is not open

if port closed - you must open port) see guide up

when port openned - you can play with friends

Share this post


Link to post
Share on other sites
  • 0
Just now, stormAD said:

I got through hamachi, 

thank you very much from the heart for the help of you two, further on I bother more @AriusII and @Jackson

glad to help :) you can evaluate my work, I think they will be useful in the development of the game

 

 

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, stormAD said:

I got through hamachi, 

thank you very much from the heart for the help of you two, further on I bother more @AriusII and @Jackson


Your welcome a pleasure to help you :) 
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...