Jump to content
  • 0

Control config screen does not properly update



I tried to add a few hotkeys to the hotkey config window. It appears this isn't only an issue with my changes, but others who have been worked in this project before me.
I added new hotkeys, Added the entries to the JSON GUI files OptionWindows. For some reason there's 2 of them, one for game and one for menus. No matter which one I update, the hotkey menu will not update. It should not look like this. Am I missing a file or something?

It's like this for whoever added guild chat and sprint too


No matter what X or Y i set those combo key labels for, or font I set, they do not move, they do not change size, They're always over another hot key, I cannot move them with the GUI files. Am I missing something, or is there some kinda bug here?

Update: Example of my Combo key Label 1 in both my OptionWindow.json, the Y position has been configured to 1064, but no matter what I update the bounds to it always draws in the same place. That Y value should put it at the bottom.

          "ControlComboKey0Label": {
            "Bounds": "8,1064,60,16",
            "Padding": "0,0,0,0",
            "AlignmentEdgeDistances": "0,0,0,0",
            "AlignmentTransform": "0,0",
            "Margin": "0,0,0,0",
            "RenderColor": "255,255,255,255",
            "Alignments": "",
            "DrawBackground": true,
            "MinimumSize": "1,1",
            "MaximumSize": "4096,4096",
            "Disabled": false,
            "Hidden": false,
            "RestrictToParent": false,
            "MouseInputEnabled": false,
            "HideToolTip": false,
            "ToolTipBackground": null,
            "ToolTipFont": null,
            "ToolTipTextColor": "",
            "BackgroundTemplate": null,
            "TextColor": "255,255,255,255",
            "HoveredTextColor": "",
            "ClickedTextColor": "",
            "DisabledTextColor": "255,225,225,225",
            "TextAlign": "Left, Top",
            "TextPadding": "0,0,0,0",
            "AutoSizeToContents": true,
            "Font": "sourcesansproblack,10",
            "TextScale": 1.0


Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

So it took me a moment, for some reason I had to delete and regenerate some gui files to copy some generated values, i dont know what was wrong with the old gui file, but after a clean generation of the code blocks I needed, it appears to be working again

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...