Jump to content
  • 0

Connection Errors with Ascension and Launcher



I have an odd issue, starting this morning (everything ran fine last night) I have an issue getting the Ascension launcher to run without an error if Discord is open. If I reboot, and just launch Ascension I can get into the game, If I launch Discord, then Acension I get a, "failed to connect to server please check our website is current and not in maintenance if issue persists please try and update the launcher from the website.". if I launch Ascension first and log in, then launch discord, I get no errors but cant talk only can listen. So far I have tried 


1 uninstalling and reinstalling discord

2. Downloading and reinstalling Ascension (which errored out on the download)

3. Disabled AV and Firewalls (though i dont think this is the issue but wanted to rule it out) . 

4. Loaded discord first then opened up retail wow to see if the problem existed there and everything worked. 


Looking for any help on resolving this issue as i am out of ideas on what the conflict currently is. Oh and forgot to mention launching discord as administrator. Thanks for any suggestions. 

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...