Jump to content

Wing67

Members
  • Content Count

    7
  • Donations

    $0.00 
  • Joined

  • Last visited

Contact Methods

  • Website URL
    http://ultramarioworld.wix.com/umwo

Profile Information

  • Gender
    Not Telling
  • Location
    Bowser's Castle

Profile Fields

  • My Project
    Ultra Mario World Online

Recent Profile Visitors

180 profile views
  1. Wing67

    Map Editor Resolution Problem

    @Damian666 that realllllllllllllly freakin sucks. What are the chances that windows 10 screws up the Map Editors in both the client and external editors, yet the client's actual game window is perfectly fine. You know any possible reason for this btw? I just find it so weird. If you ever found out this reason it should theoretically fix all the issues with the editors. : 0 If not, it may be worthwhile to maybe switch the GFX engine to something more reliable like what the Engine you linked me uses? I know nobody wants to do all that work of gutting out the GFX Engine snd putting in a new one just to fix a bug... but man does windows 10 not like SFML. May be worth considering... But anyways... I have some news I thought I should share. So, I've been hard at work trying to fix the Client's Map Editor to display the Tilesets that are bigger than the window properly and not skewed. And, I think I've gotten a reasonable fix for the fellows who are screwed by this skewing glitch like me. xD Here's a Build with the fix. I wanna know what you think about this, Damien. I'm no programming master, but I think this works pretty well. http://www.ascensiongamedev.com/resources/filehost/9a5a118452aac01a8b2e827ce3c139ec.rar The only issue with this fix is that the bigger the tileset is, the laggier the selection rectangle will be when selecting multiple tiles. This also applies to scrolling through the Tileset. It makes the cpu crank a little when doing either one of these things. I tried to find a way around it, but I seriously couldn't find a way. But, If you think this fix is competent enough, I could show you my source through PM's. Maybe it'll be decent enough to add to Orion+? xP If not I may end up making a tutorial on this anyway since this could help alot of people. P.S. Merry Christmas!
  2. Wing67

    Map Editor Resolution Problem

    @Damian666 OMG it works!!! I even tested it with one of my tilesets and it isn't skewed! What is that game's Engine? Never heard of it before. Perhaps you could use that engine's way of handling the Map Editors/GFX engine for Orion+? I mean that's obviously prob why you had me test it out in the first place. xD It seems to be glitchless, though. Maybe the out of Client Map Editor would work now too if this can fix the Map Editor Client side! I hope so, because the out of Client Map Editor is a pretty cool feature that would be neat if it was usable again.
  3. Wing67

    Map Editor Resolution Problem

    So... I've been using a laptop for a bit to work with the engine to circumvent this issue for the time being. As the glitch doesn't happen on that machine. But, honestly this laptop just cant handle Visual Studio comfortably enough to do anything past simple changes. It's just too dang slow. Then, alot of personal stuff came up and I just didn't have time to bother with it anymore... Which is why I never returned to this thread if anyone was curious. But now I got some time again and I really wanna give this engine another go. And as luck would have it, I come back to this issue seemingly being fixed! Apparently, anyways... @Damian666 It isn't fixed. :/ Yes, the Client side editor got rid of the map being horribly skewed... But now theres another issue ALMOST just as annoying and unbearable. The frickin' tilesets ALSO have this exact same issue. And this happens for both the out of Client Map Editor and the Client side editor. If you have a tileset that goes beyond the window that holds the tileset for you to click, it becomes skewed. Just like the Map Editor did in the Editors program. I simply added height to one of the stock tilesets that come with the engine and this is what happens. Just look at this crap. http://www.ascensiongamedev.com/resources/filehost/37230b237bb890142bede621923a795e.png This Glitch is unbelievably stupid and VERY, VERY unappealing for an engine to have on something as important as the Map Editor. I COULD circumvent this issue by making each tileset fit the exact window size... But come the hell on, this glitch shouldn't even be here in the first place man. And if you knew the size of one of my average tilesets I'm going to be using for my project, you would agree this glitch NEEDS to be fixed. Infact, I'll just show you guys one. Why not? http://www.ascensiongamedev.com/resources/filehost/b9a852033c236d473ae9c8ac497cddbe.png If I were to make this usable for the editor Client side, I would prob need to splice this thing up like 25 different times man. and I have 22 of these of similar size... I would have over 300 different tilesets probably if I ended up splicing them all to fit. Sorry if I'm coming off a little aggressive, Damien. This glitch is just super annoying and honestly unacceptable to have in the engine. My friends have this issue as well. Seems quite common on Windows 10 computers to the point of obtrusion. @SpiceyWolf So... what ever happened with the test you were going to do? You never updated us with the results. :( And are you still working on fixing this glitch? I really hope so... Because this glitch is awful to deal with.
  4. For tracking and organizational purposes, please include ONLY ONE bug or suggestion per report. Thank you! Reports not in English will be removed. /////////////////////////////////////////////////// Error Description /////////////////////////////////////////////////// First off, hey yall! : P It's been a few years since I've been around here. But uh... That's not the point of this thread, so I'll just get on with the problem. BTW Orion+ looks great man! I'm thoroughly impressed with how far you've come with this engine! It's soooooo much cleaner and has got so many more features compared to... what was it, early 2016 Orion? Good job! ? -THE ISSUE- I'm going to go ahead and say this may be an isolated case, I tested this on my brother's computer and his works fine and doesn't have this issue. The problem is the Map Editor's resolution is scaled all screwy when the map is not a specific size. The Cursor is desynched from the blue cube indicating where the tile is by a huge amount too. When the map's X and Y sizes is changed, the screen becomes more/less stretched according to the X and Y sizes. The Screen can look normal if you set the map size to X = 19 and Y = 16. I edited the source a bit to do that since you can't go that small normally. The issues happens if I run the built versions from THIS link and the issue happens if I download the source from github and build it myself in Visual Studio Community 2017. -MY TROUBLE SHOOTING- I tried trouble shooting the issue myself for a few hours, messing around in the source trying to find a fix... But then I tried it on my brother's computer as I mentioned earlier and it worked fine. So, I believe the issue is more related to me missing some important files or something to that effect rather than it being an issue of the coding. but idk My brother has a fresh install of Visual Studio Community 2017. While I've installed trial versions of Visual Studio 2013 and 2015 before installing Visual Studio Community 2017. I attempted to uninstall the previous 2 Visual Studios before installing Visual Studio Community 2017, but I'm not entirely sure i uninstalled every single thing. Just thought that should be said. I also checked my DPI settings and made sure it was 100%. It is. So I guess it's not related to the DPI somehow. It really seems like it would be. I've included a pic of my DPI settings if it's needed. /////////////////////////////////////////////////// Replication Steps /////////////////////////////////////////////////// Just be me. jk It was like this out of the box. I didn't touch source and the issue still happened for me. It should be noted that the Orion+ client's game screen is perfectly fine. It's ONLY the Map Editor from the Editors program that is having this issue. /////////////////////////////////////////////////// Attach Screenshots/Other media //////////////////////////////////////////////////// The RED dot is to indicate where my mouse cursor woulda been. Printscreen doesn't capture the mouse so I had to do sum editingz to insert a makeshift cusor. /////////////////////////////////////////////////// Attach Error Logs //////////////////////////////////////////////////// If you are using Intersect, please find and attach BOTH your Client/Resources/Logs folder and Server/Resources/Logs folder to help us debug your problem. Without these logs we often cannot fix bugs in the engine.
×